Get Started with Video Captioning

A Beginner’s Guide to Making Video Accessible

By Patrick Besong
Preface

This book is dedicated to all those who are new to video captioning and need to get up to speed quickly on the how and why of video captioning. I got into video captioning when I was faced with the task of making a video accessible and found that the tools available to me were either too expensive, too hard to use, or simply did not work. The process for creating QuickTime Text caption tracks seemed awfully tedious to me and I wondered why there wasn’t an easier way to do it. My response was to write MovieCaptioner, an easy-to-use, inexpensive answer to this problem. The response has been great, and I have received many requests to add different caption formats for which I had to learn a great deal to provide. It is used by many well-known companies, universities, government agencies, and independent video producers. This book should help you get started with video captioning and hopefully make you somewhat of an expert at least in some aspects of the subject in short order. Special thanks to Chris Duke of Motorz TV for allowing me to include his process of creating closed captioned video for broadcast.

- Patrick Besong
Captioning video not only makes video accessible to the deaf and hard-of-hearing, but there are other compelling reasons for it as well. These are also good talking points to convince others of the need to caption video.

- Captioned videos have better user retention of the video content.
- The video’s transcripts are searchable, so you will get better Search Engine Optimization (SEO), which may give you a leg up on your competition.
- Captioned video also opens your market reach to a whole new segment of paying customers - the deaf!
- It’s the law. Many videos that are provided to the public must be captioned either due to federal communication law, or merely a company’s policy regarding accessibility.
- Language learning relies heavily on captioned video.
- If the viewer is in a noisy area and does not have access to headphones, the captions can be read while watching the video.
- Similarly, if the viewer does not have headphones and cannot turn up the volume due to the need to keep noise to a minimum (like in a library or nursery), the captions are there to provide what is being spoken.
Better Retention of Content

Studies have shown that many people, when given the chance to view captions on a video, will turn them on to help them follow what is being said. This has advantages for retention in that they not only hear the words, but are also seeing them as well, so they are getting the information by way of two senses instead of just one. Also, another very good point is that they will be able to see the spelling of people’s names that are mentioned in the videos and vocabulary words that they may not have heard of before. They can then do a search on these names and words to find out more information if they so choose.

Search Engine Optimization (SEO)

Search Engine Optimization (SEO) is a key aspect of internet marketing. Any edge you can get over your competition can translate into a financial bonanza. Google and other search engines can now search caption files and transcripts of YouTube videos. Suddenly all the content of your video that was previously invisible to the internet becomes indexed and will show up when someone searches on that topic. Google has demonstrated this by placing obscure words that may not appear in a Web search into a video caption and after a few days will begin appearing on the search results with a link to the video. You would have to be crazy not to caption your videos today if you have an internet-based business. The return on investment is just too great to ignore.

A Bigger Market For Your Products and Services

Not only does your content become searchable when you provide video captions, but you’ve suddenly opened your doors to a whole new segment of customers, the deaf and hard-of-hearing. The Survey of Income and Program Participation (SIPP) says that nearly ten million people in the United States alone are hard of hearing and one million are functionally deaf. Doesn’t this also give you an edge over your competition if you can reach an additional eleven million people that they cannot?

New Laws Require Captioned Video

With recent legislation, another reason to caption video is simply that it is the law. In 2012, Congress passed the Twenty-first Century Communications and Video Accessibility Act of 2010 forces broadcasters to add closed captions to all programming that previously aired on TV. The laws will be revisited in the future if broadcasters are going to deliver a majority of their programming online.

In addition, state and local colleges and other post-secondary institutions must provide effective communication for deaf and hard-of-hearing students to continue to receive federal funding. Some universities such as Penn State have further required that all publicly available videos be closed captioned or transcripts provided in order to make them accessible. As you can imagine, it suddenly became a hot topic among college campuses across the country as to how they would provide this service.
Learning Foreign Languages

Language learning is another great use of captioned video. Using subtitles and captions has always been a great method of teaching and learning foreign languages. English as a Second Language (ESL) is already a huge domestic market and is growing bigger every day. Immigrants new to the United States are relying on captioned videos more than ever to improve their English comprehension and speaking abilities.

Environmental Factors

Many people find themselves in situations where they cannot hear the audio due to ambient noise or the need to keep their computers quiet, such as in a study area, and if they do not have headphones, captions can be the only way to understand what the speaker is saying.

You can see that there are some very good reasons besides accessibility to caption your videos. Besides, it’s just the right thing to do!
Okay, you’ve been given a video and told that it needs closed captioning. What does that mean exactly? Where do you start? We need to answer a few questions before we do anything. The first question you need to ask is how will this video be distributed? Will it be broadcast on television? Will it be delivered via the Internet? What site on the Internet will it be on? Will you use Flash video, QuickTime, or Windows Media? Will it be burned to DVD? Each of these formats may take a different export format for your captions and a different way of attaching the captions to the video. Let’s look at some of these.
QuickTime Movies

There are various ways that QuickTime videos can be captioned. There are embedded QuickTime Text tracks, TeXML tracks, open captions, QuickTime SMIL, soft subtitles, and Sonic Scenarist (SCC) captions.

Embedded QuickTime Text Tracks

QuickTime can use what is known as a QuickTime Text Track to add captions to a movie that are embedded into the movie itself. To do this you will need QuickTime 7 Pro. As of this writing, QuickTime X, the default QuickTime player that comes with Snow Leopard and Lion, is incapable of doing this process. It involves creating a special file with timecode and your caption text and importing it into your movie. I will explain the manual process of doing this, but let me tell you now that this somewhat tedious/clumsy task has been completely automated in MovieCaptioner. So, if you still want to do it the manual way, here is the process.

1. Start by typing up the transcripts of your movie in a text editor. Put each caption on a different line. Save the file.

2. Open the transcript in QuickTime Pro. The text will be white over a black background.

3. Export the transcript from QuickTime Pro as Text to Text, which will create a QT Text file.

4. Save it, replacing your original transcript.

5. If you open the QT Text file in a text editor, you will see that QuickTime put a lot of markup in brackets and some default timecode in for each caption, 2 seconds apart.

6. Now you will need to open this file in your text editor and open your movie in QuickTime Pro.

7. Open the Movie Inspector window in QuickTime Pro. Here you’ll be able to see the timecode easily next to the Current Time.
8. Play your movie and change the timecode in your QT Text file to match when each caption starts as listed next to the Current Time in the Movie Inspector window. The timecode will precede each caption in the QT Text file.

9. When you are done setting the timecode, save your transcript again, close it, then open it again in QuickTime Pro.

10. Select All and copy.

11. Open your target movie in QuickTime Pro.

12. Select All, but this time don’t copy.

13. Go to the Edit menu and choose Add to Movie.

14. A text track will be added to your movie at the top.

15. Open the Movie Properties window and click on the Visual Settings tab.

16. Select the Text Track, then go to the Offset and set the field on the right to the height of your movie (to put the captions below the movie) or the height of the movie minus the height of the text track (to keep the movie’s aspect ratio the same).

17. Save your movie and you’re done.
If you used MovieCaptioner to do this instead, here is the process you would follow:

1. Click the Load Movie button and load your movie into the MovieCaptioner interface.

2. Click the Start button and start typing what you hear in the 4-second loop.

3. Hit the Return key to record that caption and its associated timecode. MovieCaptioner will automatically move on to the next 4-seconds loop (this is adjustable).

4. Continue until you’ve transcribed all the audio. It will stop automatically when you’re done.
5. Export as Embedded QuickTime and you’re done.

TeXML Captions

Although QT Text captions have always been a popular way to caption videos, they have more recently become problematic. The latest few versions of the QT Player on both Mac and Windows have both had their share of issues. One example is that movies with a QT Text track will not display properly on the new Mac laptops with the retina display. It will look like this:

Note how the QT Text track fails to account for the size adjustment of the video on the retina display. It is much smaller and halfway up the video instead of being at the bottom where it was originally placed.

MovieCaptioner gets around this by using TeXML caption tracks, which are basically an XML file embedded into the movie. For some reason this works fine even on retina displays. The downside of using the TeXML files is that the text
will not wrap automatically as it does with QT Text tracks. You can add forced carriage returns in MovieCaptioner by typing the pipe symbol “|” where you want the lines to break. By hitting the Preview button at any time while transcribing, you can get an idea how wide your captions can be and put your line breaks within that limit.

You can also automatically add line breaks by going to the Edit menu and selecting **Add Line Breaks Automatically** and specifying how many characters wide you want each line to be limited to. MovieCaptioner will go through your project and add line breaks to keep your text within the boundaries of your movie.

Another advantage of using TeXML tracks is that it supports more special and accented characters than QT Text tracks do. For example, the quarter note symbol will show up as garbage characters in a QT Text track, as will many other characters. TeXML also supports Asian fonts better as well.

---

**Open Captions**

Many people have discovered to their dismay that once they embed a text track into a QuickTime movie, when they upload it to video delivery sites such as YouTube or Vimeo, the captions have disappeared. What happened?

If you take a look at your video with embedded captions in QuickTime Pro using the Movie Properties window, you will see three tracks, a Video Track, a Sound Track, and a Text Track. The video services will only take the Video and Sound tracks leaving your poor defenseless Text Track behind.
So what can you do?

There is a solution. The trick will be to combine the Text Track with the Video Track so it can’t be stripped out. You do this by re-exporting the movie from QuickTime Pro after adding the Text Track. After adding your Text Track either manually or via MovieCaptioner, open the movie in QuickTime Pro and go to the File menu and choose Export (just doing a Save As will NOT work - you must Export).

Then choose Movie to QuickTime Movie and click the Options button next to it.

You can choose your video compression settings by clicking the Video button and the sound settings by clicking the Sound button. Here are some sample settings that should yield good results. Photo-JPEG will give you crisp-looking text, however, the file size can be large. If it’s too large, choose H.264 as your compression format and adjust the quality according to your needs. There will always be a tradeoff between quality of the video and file size.
Once you’re done exporting you should have a movie with “open captions”, that is, they cannot be toggled on and off. The Text Track will now be combined with the Video track and you will be able to upload it to your video service without fear of losing your captions.

Here are the movie tracks prior to re-exporting:

Here are the exported movie’s tracks. Notice there are only two tracks now: a Video Track and a Sound Track, yet the movie’s captions are still being displayed.

Combining the Video and Text Tracks will prevent the captions from being stripped out when you upload the movie to your video service.

QuickTime SMIL

QuickTime SMIL is Apple’s version of the Synchronized Multimedia Integration Language (SMIL), which can synchronized text and video within a single file. It uses an XML file to define timing, layout, animation, visual transitions, and media embedding. At it’s simplest form it can create captions similar to embedded QT Text tracks. They will look identical, however, in the case of SMIL video, the text is not a part of the movie, but rather called in separately and played at the same time as the movie. So, a SMIL movie would require three parts, the movie, the text track, and the SMIL file (which usually has a .smi or .sml file extension). If any of these pieces are missing it will not display as desired.

A major disadvantage of using SMIL movies is that the language setting in the SMIL file must match the language of the viewer’s computer operating system. That is, if the viewer’s computer operating system language is set to Spanish and the SMIL file was created using English as the language tag, the captions will not display.

There have also been issues with more recent versions of the QuickTime Player that break the functionality of the SMIL files. For instance, on Windows, if a caption has a separate text formatting (font, style, size, etc.), you may get an invalid caption file and no captions will be displayed.

Also, other movie players, such as Windows Media Player and Real Player may already have the .smi or .sml file associa-
tion and will not be able to play QuickTime’s version of the SMIL file. This would again result in no captions.

For these reasons, I would not recommend using the SMIL format to deliver captioned video.

**Soft Subtitles**

A little-known way of displaying captions on QuickTime movies is soft subtitles. These are surprisingly easy to create and can be toggled on and off in the QuickTime Player under the View > Subtitles menu option. You will need to use MovieCaptioner and a freeware app called Subler.

To create the captions, you will need to create a SubRip SRT caption file which looks like this:

You have the caption number, then on the next line is the timecode begin and end times separated by “--->”, and on the next line is the actual caption. A caption may run more than one line by adding a carriage return at any point and typing the rest of the caption on the next line. Then there is a blank line, then the next caption’s number is on the following line. Note that the decimal in the timecode is replaced with a comma. This is because the SRT format was invented in France and that is the way they display their decimals.

The SRT file is simple to create using MovieCaptioner. After transcribing all your captions, it’s as simple as choosing SubRip SRT from the Export menu.

Once you have your caption file in SRT format, launch Subler. Drag your movie into the Subler interface, click Add, then drag the SRT file you created into the Subler interface and click Add for that as well.
Now just Save and give the new movie a name. It will have the MP4 file extension, which supports SRT caption tracks. After your movie is saved, open it in the QuickTime Player and under the View menu make sure that the captions are turned on under the Subtitles option.

The subtitles will look like this:

A downside to soft subtitles is that they don't seem to work in the browsers, as is the case with many formats, unfortunately. The viewer would have to actually download the movie to see the captions in the QuickTime Player. As a side note, you can get a similar style of captions by checking the Translucent Background box in MovieCaptioner’s Text Properties area.
Sonic Scenarist (SCC) Captions

This is the style of captions you see on TV with the white text over a black background. They look like this:

SCC captions are a relatively old format that has been used for television for many years. Apple made a special plugin for QuickTime called the ClosedCaptionImporter.component that made it possible to add this style of captions to QuickTime movies if you have QuickTime 7 Pro installed. The process is the same for adding QuickTime Text captions to movies as outlined earlier. MovieCaptioner has a special export available on Mac computers that have this plugin. By exporting as Sonic Scenarist (SCC, Embed in QT), it will automatically create the SCC caption file and add it to the movie. The movie must be an MPEG-4 (MP4) movie or the captions will not be viewable again the next time you quit QuickTime Player and open the movie. For example, if you embed SCC captions into a .mov movie file, the caption track will be added and you will see your captions. But if you quit out of QuickTime Player and open it again, even though the caption track is still there, the captions will not display even if you select Show Closed Captioning from the View menu. So you must use an MP4 movie if you want to save your captions. You can use this export to test how your SCC captions will look in your final movie, however, if you’re going to tape from Final Cut Pro or adding captions via Compressor.

Embedding SCC captions into an MP4 movie will allow your captions to display on an iPad in an iBook if closed captioning is enabled on the iPad. To enable closed captioning on the iPad, go to the Settings, scroll down on the left until you find Videos, select it and Closed Captioning should appear on the right. Then just slide the switch on and closed captioning will be enabled.
You can also embed SCC captions using Subler, a free captioning program that was mentioned in the Soft Subtitles section. With Subler you can use any movie and it will convert it to MP4 with captions upon export.

Although they look the same as the captions you see on TV, QuickTime's implementation of SCC captioner are different, so they are typically not up to spec for use in broadcast television. They will, however, work on iOS devices like iPods and iPads. MovieCaptioner has been used to create closed captioned iBook movies as well.

A typical SCC caption file opened in a text editor my look like this:

![SCC Caption File]

After the “Scenarist_SCC V1.0” format marker each line after that contains the start timecode for each caption. The caption itself is converted to hexadecimal digits arranged in sets of four with a space between. Some of these digits are formatting, that is telling the output device where to indent and break lines and the rest are the captions themselves.

According the the specifications for SCC captions, you can have up to 32 characters per line and no more than 4 lines per caption. Anything longer will get truncated and will not display correctly if it doesn’t create an invalid file first. You can also alter where the captions are located over the movie.

The SCC format consists of 15 rows where text may be displayed. Row one is at the top and row 15 at the bottom. By default, MovieCaptioner places all captions on the bottom row at 15. If a caption is more than one line it will automatically start high enough that the last line will fall on line 15. The row can be changed by selecting a different row from the SCC Row pull-down menu and then clicking the Change button next to it.

![SCC Row Options]

Although the SCC specification allows for pop-on, roll-up, and paint-on captions, MovieCaptioner currently only outputs pop-on captions.
Adobe has recently added the ability to display SCC captions in Premiere CS5.5. It does, however, use a slightly different version of the SCC specification and MovieCaptioner supports this as another SCC export option called Sonic Scenarist (SCC file, Premiere Compatible).

Flash XML

Adobe Flash supports DFXP caption files. DFXP stands for Distribution Format Exchange Profile and is used by video players that support TTML (Timed Text Markup Language) captions. DFXP caption files are XML files that contain the timing, font properties (in style tags), and captions. They look like the sample you see below.

The XML file must be linked within Flash to a video player skin that contains a closed caption element. The name of the skin will have “Caption” in its name such as “SkinUnderPlayCaption.swf.” In addition, the “FLVPlaybackCaptioning” component must also be implemented (by dragging it to the Flash stage next to your video skin) and the XML file is linked to the video via this component’s source parameter. In the image below the source parameter is set to “captions.xml,” the name of our DFXP file exported from MovieCaptioner.

In this example the “captions.xml” file would have to be in the same folder as the Flash video file calling it. Don’t forget to upload the Flash SWF file, the FLV movie, the player skin (“SkinUnderPlayCaption.swf” in this case) and your XML file.
When you play the video if the closed captions button is turned on the captions will appear on the bottom. You can control the text properties for them in your XML file.

Brightcove (http://www.brightcove.com), an online video platform also uses the DFXP-TTML format, however, their implementation is stricter to the DFXP specifications and MovieCaptioner provides a special export for their video captions.

YouTube in the past several years has provided the ability to add captions to the videos that you upload to their site. After uploading your video, go to your video’s page and click the CC+ button below your video.

Click on the blue button and locate your caption file or transcript on your computer.
YouTube can accept files in many popular formats: SRT, SBV, SCC, DFXP, SMI, LRC, RT, and STL.

Once you select your file, you can select which language your file is in and give the caption track an optional name. Click the correct radio button for either a Caption file, which includes timecode or a Transcript file, which does not. Then just click the Upload button and your captions will be viewable the next time you watch your movie. YouTube will attempt to time the captions automatically if you upload a transcript with no timecode.

Other video services, such as Vimeo, may not provide the option of uploading a closed caption file. In this case you should embed the captions into the movie and then export again after the captions are added, which will combine the captions with the video track so that they will not be stripped out when the movie is uploaded. See the section on Open Captions for more details.

**JW Player**

The JW Player is another option for delivering videos. This is a video player that you would embed into your HTML page. It supports both Flash and HTML5 video. It is free for non-commercial Web sites, but there is a tiered charge for commercial use. The JW Player Captions Plugin is required for delivering video with captions. The JW Player can use either SRT or DFXP captions. MovieCaptioner currently exports the DFXP format for the JW Player, however, you can use the SRT or YouTube export instead if you prefer to use the SRT captions.

The caption file will be linked to the JW Player in the embed tags. An example of using three different SRT captions is shown below:

```html
<script type="text/javascript" src="/jwplayer/jwplayer.min.js"></script>
<p id="container">The player will be placed here</p>
<script type="text/javascript">
    jwplayer("container").setup({
        file: "/assets/video.mp4",
        flashplayer: "/jwplayer/player.swf",
        height: 360,
        plugins: {
            "captions-2": {
                files: "/assets/deu.srt,/assets/fra.srt,/assets/ita.srt",
                labels: "Deutsch,Français,Italiano"
            }
        },
        width: 640
    });
</script>
```
More information on JW Player captions can be found here:

Windows Media Player SAMI Captions

Windows Media has its own version of captions that use the SAMI (Synchronized Accessible Media Interchange) format. This format is similar to Apple’s SMIL captions, and in fact uses the same “.smi” extension that Apple uses for its version. This can cause issues between the two video players if one is set in the File Associations to use that extension and you try to play it in the other. If you try to open your SAMI file and another application like QuickTime or RealPlayer opens it instead, just right-click the file and choose Open With and then choose the Windows Media Player. Be sure to check the option to always open that type of file in Windows Media Player. Also note that SAMI files do not play very well in the Mac version of the Windows Media Player if at all. They are also not a good choice for using in a Web page due to the lack of availability of the plugin.

A typical SAMI file starts with the <SAMI> tag and has markup very much like HTML and in fact can use many of the same tags. It also uses style sheets to control text properties. The first caption should always start with <sync start="0"> and the last should contain the duration of the movie in milliseconds. There are 1000 milliseconds in a second. The file should be saved using UTF-8 encoding (an option when you save) in order to properly display captions.

If you name your SAMI file with the same name as the movie only with the “.smi” extension, the captions should be
available to the Windows Media Player if captioning is enabled in the Windows Media Player.

If it is not named the same, an XML file with the “.asx” extension can be used to marry the movie file with the SAMI caption file. This occurs in the <ref> tag of the XML file.

The ASX file is an XML file that looks like this:

```
<asx version="3.0">
  <title>
    Captions for wacs.mov
  </title>
  <entry>
    <ref href="wacs.mov?sami=wacs.smi"/>
  </entry>
</asx>
```

Opening the ASX file will enable captions to be displayed in the Windows Media Player. You will need to make sure that all 3 files, the movie, the SAMI file, and the ASX file are present in the same directory when using the ASX file as the main file.

**WMP Text Files**

Another Windows option that eliminates the need to use three different files for delivery is WMP Text files. These can be embedded into the Windows Media movie file using the Windows File Editor, part of the Windows Media Encoder 9 application on a Windows computer.

The WMP Text files are XML files that have the following basic markup:

```
<xml version="1.0">
  <WMBasicEdit>
    <RemoveAllMarkers />
    <RemoveAllScripts />
    <Scripts>
      <Script Type="CAPTION"
        Command="q"
        style="&quot;text-align:center;font-family:Arial;font-size:14;color:#FFFFFF;background:#000000&quot;: At an Army Air Force base in<br>Arizona, &lt;p&gt;
        Time="336000000"&gt;
      </Script>
</WMBasicEdit>
```

The timecode is basically the number of seconds from the beginning of the movie x 10,000,000. It’s much easier just to let MovieCaptioner figure it out for you. It is just a one click export.

Here is the process to embed the file in your video:

1. Open the Windows Media File Editor application. You will find it in Windows Media Components\Encoder\wmedito.exe
2. Go to **File > Open** and select your WMV movie.
3. Go to **File > Import Header File** and select your WMP Text file.
4. Go to **File > Save As and Index**
Once the movie is done saving you should be able to see your captions in the movie when played in the Windows Media Player.

You may instead use SRT files if you have the newer Windows Expressions Encoder 4 application. Make sure prior to exporting your SRT file that there are no line breaks in each caption. These can be removed easily in MovieCaptioner by selecting the Delete All Line Breaks “|” in Caption List option under the Edit menu. If you have line breaks in your SRT file, only the last line of each caption will display in the final captioned WMV file using Windows Expressions Encoder 4.

1. Open Windows Expressions Encoder 4 and make a new Transcoding Project.
2. Go to File > Import and select your movie.
3. Go to the Script Commands panel and select Import and find your SRT file. Script Commands is in the Metadata panel. Expand its gear icon to get to the Import link.
4. Each caption will show up in the list in the Script Commands panel. You can make edits here prior to saving your movie.
5. Before you encode your movie with captions, go to the Window menu and make sure that Metadata, Encode, and Output are all checked.
6. Set your encoding preferences in the Encode panel and then go to the Output panel and select the destination of the final file.
7. Go to File > Encode to begin the encoding process. When it’s done you should be able to see the captions in your video.
Broadcast Video (Line 21) Closed Captions

A common question I get asked is “How do I prepare my video for broadcast with closed captioning?”

Now that videos need to be closed captioned before they can even be submitted to a broadcast station, many people are in a panic as to how to go about it. Luckily, it isn’t too difficult if you have Compressor for the Mac. Here is the process (courtesy of Chris Duke of Motorz-TV):

1. Locate your Quicktime .mov file in Finder. Right-click it and select Open With > Compressor.

2. Locate from the Settings window, Settings Tab, locate Apple > Formats > MPEG-2 > Program Stream. Check the properties in the Inspector window to make sure they match what your network is looking for. If it differs, duplicate the MPEG-2 Program Stream setting and make your changes (it will then show up in the Custom group/folder).

3. Drag that setting to your video above in the “Untitled” window. It should look similar to this:

4. Now pair your .scc file, which contains your closed caption text, to your video. Click the thumbnail. You will see the tabs in the Inspector window change. Select the “Additional Information” tab, then under “Closed Caption file” click the “Choose...” button and select your .scc file.

5. Now that you’ve selected your MPEG2 program stream profile and your .scc file, you’re ready to go!

6. Click the “Submit...” button and Compressor will get to work. Here’s a tip here: check “include unmanaged services on other computers” even if you don’t have any other services or any other computers. This will use the full power of your CPUs. For example, on my 8-core Mac Pro which shows up as 16 CPUs, if I don’t check this box Compressor will use only 8 of my CPUs. By checking this box, Compressor uses all 16 CPUs and things will go a lot faster!

Once Compressor is finished, you will have a .mpeg file in the same folder as your .mov. So how do you view the closed captioning? I have yet to figure this out with the Quicktime Player (v7 or “X”) but I will tell you what does work.
1. Download the free VLC Media Player. Open your .mpeg file using VLC.

2. Go to the Video menu and select Subtitles Track > Closed Captions 1

3. Wait for a few seconds of video to pass and you should see your CC text at the bottom of the screen. Note that initially it may appear garbled as VLC tries to pick up the encoded text. Don’t panic. It’s probably fine (watch it again to confirm). Also, the way the text appears in the VLC player is not how it will appear on TV. This is just a font style the player uses to render your text.

[Note that QuickTime cannot display the type of SCC captions that Compressor adds to the movies. You must, as Chris mentions, use VLC Media Player to make sure your captions have been added.]

Chris Duke, Executive Producer, and Host, Motorz TV

In 2008, Chris launched Motorz TV, now the fastest growing nationally televised Automotive Improvement series of its kind. Unlike other automotive shows that skip important steps during commercial breaks, use expensive tools, or perform feats that would be impossible for the average viewer, Motorz shows viewers how to confidently and properly maintain a vehicle and install aftermarket accessories with simple step-by-step instructions in a home garage environment.
There are various software titles that can be used both in part or exclusively in creating captions. Let’s take a look at some of these and how you might leverage them in captioning your videos. This is not an exhaustive list, but these are the ones that I have used and find to be very helpful in video captioning.
MovieCaptioner was created to make it easy for anyone to make their videos accessible. In fact, if you can type, you can make your movies accessible! MovieCaptioner is QuickTime-based, so it’s best to have a QuickTime movie (.mov) or an MPEG-4 movie (.mp4 or .m4v). You can also use other video formats such as Flash (.flv) or Windows Media (.wmv) if you have the right plugins for QuickTime (the free Perian plugin from http://www.perian.org or the free Flip4Mac plugin for Windows Media, available from http://www.telestream.net/flip4mac/overview.htm). Unfortunately these plugins are not available for the Windows version so Windows users must use either a “.mov” file or an mpeg-4 movie.

Using MovieCaptioner is really very easy.

1. Click the Load Movie button and find your movie on your computer.

2. Set the Text Properties the way you want them. Whatever is selected will be attributed to any new captions you set.

3. Click the Start button in the lower left of the MovieCaptioner interface (not the movie’s Play button)

4. MovieCaptioner will begin looping the first 4 seconds of the movie. Just type what you hear and when you’re done typing that 4 seconds of the movie, just hit the Return key to set that caption. Its timecode will be recorded next to it.

5. MovieCaptioner will continue on to the next 4 seconds automatically after you hit the Return key. Just keep typing what you hear and hitting the Return key to caption your movie.
6. After the last caption, MovieCaptioner will stop automatically.

7. At any point you can click the Preview button and see how your captions will look as embedded QT captions.

8. You can choose from many different export formats including YouTube, SCC for broadcast, iOS devices, and DVDs, embedded QuickTime, Flash, HTML5, and many others. You can also export transcripts.

MovieCaptioner is available from Synchrimedia. A 14-day fully functional demo is available to download on the website, so you can try it out and make sure it does what you need it to do. It is simply the easiest way to caption your videos!
QuickTime 7 Pro

QuickTime X, the default QuickTime Player that comes with OS X on the Mac will not allow you to add captions to your movie. You will need to download and install QuickTime 7 from the Apple Web site or get it from your OS X install disc using a Custom Installation of just that application. You will not need to uninstall QuickTime X. The two versions of QuickTime can peacefully co-exist on the same computer. After installation, you’ll find that QuickTime 7 will be installed in your Applications/Utilities folder on your Mac.

QuickTime 7 can be upgraded to unlock its many editing features, and although it is not required, I strongly recommend buying the upgrade to the Pro version from Apple. It is $30 well-spent as it will allow you to not only manipulate movie tracks, but it will also allow you to export movies in different formats and do minor editing.

It will also allow you to see the movie’s properties by going to the Movie Inspector window.

It will also give you access to the Movie Properties window, which will allow you to manipulate the movie’s tracks in various ways. Tracks can be extracted or deleted, the Text Track can be moved up or down by adjusting the Offset setting, they can be scaled, and even the transparency can be changed.

Exporting as a new movie also gives you many choices as to how you want to output your movie with control over many aspects of the quality of the video and sound.

QuickTime 7 Pro is in short a great tool to have if you’re going to be doing a lot of video captioning.
BBEdit and TextWrangler

BBEdit is one of the best plain text applications you can have in your toolbox. If you don’t want to buy it, however, their free version, TextWrangler is an excellent substitute and does most of the same things BBEdit can do.

Having a plain text editor is a must for doing captioning. When importing text into MovieCaptioner, it’s often necessary to resave your text document. If you try to import a Microsoft Word document directly into MovieCaptioner, chances are you will see a bunch of garbage characters that represent invisible text styling. Characters like “smart quotes” that you see above those words that look like little sixes and nines will cause issues if they are imported or pasted into MovieCaptioner. Another such character is the curly apostrophe ’ that you see in this sentence. It looks like a little nine. The single ‘quotes’ have the same issues as does the ellipse character that looks like three periods close together …

To get rid of these characters, it’s best to save your Microsoft Word or RTF file as plain text, and then open it in BBEdit or TextWrangler. Go to File > Save As and choose Unicode (UTF-8) for the encoding. This should convert the characters into their supported counterparts. Save as a text file prior to importing into MovieCaptioner and you’ll save yourself a lot of headaches.

Use the Zap Gremlins option under the Text menu to see if there are any unsupported characters.

You might also use TextWrangler to open any transcript files you export from MovieCaptioner as well, and sometimes it will come in handy for a few of the MovieCaptioner exports such as SAMI captions or HTML5/Timesheet if you need to go in and tweak the exported files to reflect the web address to your movies.

They can also do powerful searches through your exported text files if you need to change something after exporting or for troubleshooting. It can Find/Replace and can also use grep searches which are coded searches that look for specific patterns.

Another feature I find helpful is the Find Differences option under the Search menu. It can compare two plain text files and tell you which lines are different in each and show you where those differences are. This can come in handy when troubleshooting how one file works and another does not.

Made by Bare Bones Software.
**Notepad++**

Notepad++ would be the equivalent of BBedit on the Windows platform. It has syntax highlighting, regular expression search/replace, a customizable GUI, auto-completion, and more.

A couple features that I like are that it has an Encoding menu to easily change files to UTF-8 encoding so they'll work better with MovieCaptioner.

It also displays line numbers and can show characters such as line endings. A must-have for Windows users.

Notepad++ can be downloaded free of charge from [http://notepad-plus-plus.org](http://notepad-plus-plus.org).

**MPEG Streamclip**

This is a great little free application that allows you to resave your movies in MPEG-4 format. This is particularly handy if you need to add SCC captions to a movie for iOS.

You can use MPEG Streamclip to: open most movie formats including MPEG files or transport streams; play them at full screen; edit them with Cut, Copy, Paste, and Trim; set In/Out points and convert them into muxed or demuxed files, or export them to QuickTime, AVI, DV and MPEG-4 files with more than professional quality, so you can easily import them in Final Cut Pro, DVD Studio Pro, Toast 6, 7, 8, and use them with many other applications or devices.

Supported input formats: MPEG, VOB, PS, M2P, MOD, VRO, DAT, MOV, DV, AVI, MP4, TS, M2T, MMV, REC, VID, AUD, AVR, VDR, PVR, TP0, TOD, M2V, M1V, MPV, AIFF, M1A, MP2, MPA, and AC3.

One of the biggest reasons I like MPEG Streamclip is that it can resave a movie that was compressed using AVC Coding to something that will work for video captioning. AVC Coding can cause lots of problems when trying to add a text track.

MPEG Streamclip works on both Mac and Windows and can be downloaded free of charge from [Squared5](http://www.squared5.com).
Subler

Subler is an Mac OS X app created to mux mp4 files. This application comes in handy if you want to add SCC captions to a MP4 movie.

The main features are:

• Creation of tx3g subtitles tracks, compatible with all Apple's devices (iPod, AppleTV, iPhone, QuickTime).

• Mux video, audio, chapters, subtitles and closed captions tracks from mov, mp4 and mkv.

• Raw formats: H.264 Elementary streams (.h264, .264), AAC (.aac), AC3 (.ac3), Scenarist (.scc)

• iTunes metadata editing and TMDb and TVDB support.

To add SCC captions to an MP4 movie, just open the movie in Subler, then drag your SCC file that you exported from MovieCaptioner into the Subler interface and click Add. After the SCC caption file is added, go to the File menu and choose Save As and save it as a Video-MPEG (MP4) movie. The captions will be visible in QuickTime and on iOS devices if Closed Captioning is enabled.

The same technique with Subler can be used to add SRT caption files to a movie as well. Just load your movie, click Add, then load your SRT and click Add. Save your movie as Video-MPEG and you will have subtitles when you view it in QuickTime Player and VLC Player. Subler is available from Google.

VLC Media Player

VLC is another free video player that is helpful in at least one novel way. It can display SCC (Line 21) broadcast captions for MPEG-2 Transport Stream (MTS) video. So, for example if you use Compressor to add SCC captions to an MPEG-2 Transport Stream, you can check to see if the captions were properly installed by opening the resulting movie in VLC Player. Go to the Video menu and choose Subtitles Track to see if your captions were indeed added to your movie. Note that they will display differently in VLC than they will on air, but at least you will know they are there and can send the captioned video on to your broadcaster.

It can also play most anything: Files, discs, webcams, devices and streams. It can play most video codecs with no extra downloads needed: MPEG-2, DivX, H.264, MKV, WebM, MP3, and more. It can also do media conversion and streaming. Quite a handy tool in your video arsenal!

VLC Media Player is also a free, cross-platform software that you may download from VideoLan.
Compressor

Compressor, made by Apple, is a video encoder that is a must-have if you are going to be creating videos for broadcast TV that need to include CEA-608 (Line 21) closed captions or for use on iBooks and other iOS devices that need to support closed captioning.

Compressor comes with many presets that make the process of adding your SCC caption file to the video very easy. If the station transcoding the file has the right equipment (such as the Telestream Vantage), they can translate the CEA-608 closed captions from your SCC file to CEA-708 closed captions for HD video as well. The only drawback is that the home viewer would not have the ability to change the font size and other attributes as they would be able to with the true CEA-708 captions. So they would look the same as the regular Line 21 captions to the home viewer.

See the section in Captioning Formats to see how Chris Duke, of Motorz-TV uses MovieCaptioner and Compressor to output his nationally syndicated car program with closed captions.

Compressor is available on the Mac App Store.

SCC Caption Decoder

If you’re going to be using a lot of SCC caption files, this can be a very handy tool to have. Since SCC files are set in hexadecimal code, they are unreadable. SCC Caption Decoder will take your SCC file and create a human-readable transcript from it. This can be invaluable in troubleshooting SCC caption files, which can sometimes be problematic, since they do not support special characters, such as smart quotes, curly apostrophes, em-dashes, and ellipses that can cause invalid SCC files.

SCC Caption Decoder is available from Synchrimedia and also has a 14-day fully functional demo so you can try it out.
**Miro Video Converter**

A beautiful, simple way to convert almost any video to MP4, WebM (vp8), Ogg Theora, or for Android, iPhone, and iPad. Batch conversion, custom sizing, and more!

This could be a handy tool especially for Windows users who may need to create a QT movie or MPEG-4 movie for use with MovieCaptioner.

100% Free and open-source from Miro.

---

**Dragon Dictate (Mac) and Dragon NaturallySpeaking (Windows)**

Say words and watch them appear on your computer screen — three times faster than typing — with up to 99% recognition accuracy right out of the box. Correcting or revising your dictated text is simple with a new, more powerful correction interface that lets you quickly edit words or phrases. Dragon Dictate adapts to your voice and the words you use to deliver better recognition results over time. You can personalize Dragon with your own custom vocabulary of acronyms, proper names and other unique phrases that you frequently use. Dragon can even adapt its format rules by detecting your format corrections — abbreviations, numbers, and more — so your dictated text looks the way you want it to every time. Review your work with Dragon Dictate’s Text-to-Speech feature, which reads back editable text for easy proofing or multi-tasking.

Dragon also works with MovieCaptioner. Instead of using a text editor to caption your speech to text, you can listen to the video loop in MovieCaptioner and repeat what you hear in your headphones into your microphone. Dragon will type the text into the MovieCaptioner text box. Just hit the Return key after it types what you say and it will proceed to the next loop of the video.

Dragon Dictate and Dragon NaturallySpeaking are available from Nuance.
There are certain ways of displaying captions that will make them more visually pleasing and easier to read, which can greatly assist the viewer in understanding the video’s content. Most are common sense, but all are helpful to the viewer.
**Accuracy**

The most important thing to remember about captioning is to make the captions as close to a replacement of the sound as possible. This means that captions should be on time with the sound and provide the same meaning as closely as possible. There are some times when accuracy may take a back seat to readability. That is, if there is too much text to be comfortably read by the viewer within the span of the audio representation, then some paraphrasing or word substitution may be in order if it can convey the same meaning as the spoken word.

Accuracy can sometimes be taken to a fault as well. Consider when people say “um” in order to fill blank spaces in their speech. It does not make for very good reading to include every “um” that the speaker utters. It’s generally better to leave them out so that the meaning can be more efficiently conveyed. Another example of selective accuracy may be when someone obviously misspeaks and corrects themselves immediately. The corrected version should be the only one included. Take for example:

To wash your car, first fill your sponge -
I mean your bucket - with water.

It might be better to just type:

To wash your car, first fill your bucket with water.

The same message gets across only in a less confusing fashion.

**Readability**

Using mixed case is preferred instead of all caps. This is because people tend to read by recognizing the shapes of words and less by actually reading them letter-by-letter. Take for example the same sentence written both in mixed case and all caps:

**The clever fox jumped over the lazy dog.**

**THE CLEVER FOX JUMPED OVER THE LAZY DOG.**

The first version in mixed case is much quicker to read and this slight increase in speed makes a huge difference when you’re reading captions in an hour-long video. An exception to this would be to use all capitals to indicate someone screaming.

Also, it is best that you use no more than two lines per caption. If there is only one line, it should be centered towards the bottom of the screen. An exception to this would be if the captions would interfere with important visuals at the bottom of the screen. SCC captions allow each caption to be presented on different rows (1-15 with 1 being at the top). If there is more than one line, then the lines should be left-justified and the longest line should be centered for best readability.

Speakers can be denoted by putting their names in parentheses:

(Sue) Do you think she’ll live, Doctor?
(Dr. Wolf) Time will tell, Sue.
This can be important when there are more than two speakers in the video. If there are only two speakers, you may denote a change in speakers either by using the double karat:

>> Do you think she’ll live, doctor?
>> Time will tell, Sue.

Sound effects can be denoted by placing them in brackets:

[ car horn honks ]

They should also be in lower case. You can also use this method to show what the speaker’s emotion is:

[ astonished ]
I can’t believe what I’ve just witnessed!

Music can be denoted by placing the eighth note symbol before and after each caption, and the end of the song gets two eighth notes:

♪ Happy birthday to you ♪
♪ Happy birthday to you ♪
♪ Happy birthday dear Joey ♪
♪ Happy birthday to you ♪ ♪

If there is a significant pause, you may use the ellipsis:

My darling...will I ever see you again?

Do not use an ellipsis to indicate that the caption continues on to the next caption. This is understood. It is quite acceptable to break captions in the middle of sentences. However, if you can complete a sentence within a given time where it does not make the caption too long, then doing so is preferred.

If quoting from a book, start the quotes on the first caption of the quote and do not put them in until you are done with the quote, even if it is several captions long. The last caption of the quote should have the ending quotes.

“Once upon a time there lived a beautiful princess.

She hoped that one day she would meet her handsome prince.

But she never did.”

It is generally preferable to use numbers instead of writing them out:

Jill bought 3 loaves of bread, 2 dozen eggs, and 1 gallon of milk to make French toast.

Basically, try to keep the reader in mind. Most of these suggestions are pretty much common sense to make reading captions easier for the viewer of the video. Remember that they are both watching the video content and trying to read, so good form and efficiency is key! Try to be as specific and accurate as possible so that they get as much of the experience of the video as those that can hear the audio.
Helpful Video Captioning Related Links

• **Synchrimedia**
  Download a 14-day, fully functional demo of MovieCaptioner, the easiest way to caption your movies.

• **MovieCaptioner Tutorial Videos**
  Watch these short videos to get up and running very quickly with MovieCaptioner.

• **Reading Between the Lines**
  Blog by Synchrimedia where you can learn about a lot of technical issues and tips related to video captioning.

• **Creative Cow Closed Captioning Forum**
  This is a great place to post questions about anything that has to do with closed captioning. The people who moderate and contribute are quite helpful!

• **WebAIM**
  Lots of great info on accessibility, captioning formats, how-to, and best practices here.

• **3PlayMedia Captions Format Converter**
  Convert your caption file to one of seven formats.

• **Closed Captions and the SCC Closed Caption Format**
  Everything you ever wanted to know and more about the SCC format for creating Line 21 captions.

• **Creating Closed Captioned DVDs on Windows**
  Using DVD-lab Pro

• **Creating Closed Captioned DVDs on a Mac**
  Using DVD Studio Pro. This is a YouTube video created by Automatic Sync Technologies.

• **Create Closed Captioned Broadcast Video**
  Motorz TV host Chris Duke’s blog that shows his process for creating closed captioned video for broadcast using MovieCaptioner and Compressor.

• **Automatic Sync Technologies**
  Automatic Sync Technologies (AST) leverages leading-edge technology and professional stenographers to power its CaptionSync service; a fast and simple web-based solution for generating captions, transcripts and video search data for a variety of video at a great price.

• **3PlayMedia**
  Provides premium captioning, transcription, and translation solutions that help publishers get more value from their video. Their goal is to simplify the workflow through flexible APIs, a secure online account system, and integrations with a multitude of players, platforms, and lecture capture systems.

• **East Texas Captioning**
  East Texas Captioning, an affiliate of Synchrimedia, offers file conversion and other closed captioning services. They can take your MovieCaptioner project file and output whatever you need as far as captioned video is concerned, whether it’s just another file format that MovieCaptioner cannot offer or the final captioned HD movie.
Patrick Besong is currently a multimedia manager for Penn State’s Education Technology Services department. He has a B.A. in Art from Penn State where he was a varsity gymnast from 1978-1981. He worked as a technical Illustrator at HRB-Singer (now a division of Raytheon) until 1990 and began working at Penn State as a graphic designer and chyron designer for WPSU, Penn State’s PBS station. He then worked as an instructional technologist for Penn State’s World Campus online learning initiative and in 1999 took a position with SMGnet creating Web-based business simulations. He returned to Penn State in 2001 as a multimedia specialist, creating interactive learning modules in Flash for courses. He took an interest in video accessibility and eventually wrote MovieCaptioner, an easy-to-use software that helps people make their videos accessible. He started Synchrimedia as a side venture and also has two other software titles, SCC Caption Decoder and ScreenCaptureX.

Patrick also holds a first degree black belt in Tang Soo Do and enjoys weightlifting, running, classic cars, bad puns, and spending time with his family in Snow Shoe, PA.

He can be reached via email at pzb4@psu.edu or via his business email at synchrimedia@gmail.com.